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Introduction
Congratulations on your decision to use Gantner Instruments as your source for a high
performance data acquisition and control system. The software tool test.commander is the
single software required to configure a complete Gantner system. This guide will describe the
different features and capabilities of test.commander and how it is best utilized.
Purpose
Any Gantner system that utilizes a Gantner controller (i.e. Q.gate, Q.pac, or Q.station) requires
test.commander for configuration. This includes but not limited to sample rate settings,
synchronization, interfaces, calculations, data logging, and channel configuration. Every copy of
test.commander includes ICP100 and test.viewer. ICP100 is the channel configuration tool of
measurement modules and test.viewer is the data visualization and analysis tool of acquired
data.
Downloads
The latest and greatest version of test.commander can be downloaded directly from the
Gantner Instruments website:
http://www.gantnerinstruments.com/software%20downloads/test.commander.zip
The newest version of test.commander contains the most up to date versions of controller and
measurement module firmware. A new installation of test.commander on a new PC will be
installed in DEMO mode. In order to configure a complete system, a LICENSED version of
test.commander is required. Inquire with your local Gantner Instruments vendor on how to
obtain a license for test.commander.
Recommended PC Requirements







Windows XP
4 GB RAM
Dual Core Processor (2+ GHz)
Ethernet Port
USB Port
Data Storage (depends on application)
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Installation
1. Download the most recent version of test.commander from the Gantner Instruments
website.
2. Unzip the contents of the ZIP file.
3. The Setup.exe file will be found in the unzipped folder. Double-click on this file to start
the installation process.
4. After the installation process has completed, double-click the test.commander icon.

5. Before connecting Gantner hardware to test.commander, make sure to configure the
correct IP address settings of the PC and to provide the proper exceptions in the firewall
for Gantner software tools. See the PC Configuration section of the Q.bloxx Quick Start
Guide for more details.

Starting test.commander
1. The first thing to make sure test.commander is useable is to change the language
settings. The software can be used in one of the following modes:




English
French
German

2. If test.commander starts in German, navigate to the following location:
Extras > Einstellungen
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3. Navigate to Sprache.

4. Select English.

5. Click the OK button to save the new setting. Restart test.commander.
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Licensed Version
1. Start test.commander.
2. Select Help > About.

3. Select the License button.

4. Enter the license information exactly as obtained from your Gantner vendor.

5. After the information is entered correctly, the LICENSED version will be displayed.

8 | Released: 3/16/15

Creating a New Project
1. When test.commander opens, a window displays several options on how to start a
project.
We recommend choosing either Open new project or Open existing project (if one has
been previously created).

2. For this guide, we will create a new project; therefore give the new project a name. The
project files will be saved in the default location of the Gantner Instruments directory.

3. A blank test.commander project is ready to be used.
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Scanning for Controllers
1. Controllers shipped from the factory have a default static IP address of 192.168.1.28.
While this configuration will work for some networks, the static IP address of the
controller might need to be modified for others.
2. Select Utilities > Controller Network Terminal.

3. The Network Finder window will open and show all controllers connected to the PC,
even if they are on a different subnetwork. The IP, Subnet, and Gateway of the
controller are displayed.

4. If the default settings of the controller are sufficient, close the Network Finder window.
To modify a controller’s IP address, highlight the controller to configure.
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5. The controller’s IP address, Subnet mask, and Gateway address are placed into the
appropriate cells. Manually enter or modify these settings here. Click the Config button
to apply the new settings.

6. The controller will restart after the changes have been made. Click on the Refresh list
button to view the updated settings.

Updating Firmware
Controller
1. Make sure the most updated version of test.commander is installed or the firmware to
update to is on the same PC. Note: any test.con project loaded on a control is erased
during a firmware update.
2. Select Utilities > Controller Firmware Update.
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3. The DLL Scanning Network window will scan for and display all connected controllers.
Highlight the controller to update and click the OK button.

4. IMPORTANT: Do not disconnect power or communications to the controller during the
update process.
5. The controller will restart automatically at the end of the update process.

Slave Modules
1. Similarly make sure the most updated version of test.commander is installed to ensure
the most up to date version of the firmware is loaded on the PC.
2. Select Utilities > Slave Firmware Update.
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3. The Slave Firmware Update window will appear. Click on the perform Scan button.

4. Highlight the controller to scan and click on the OK button.

5. The software will scan all available UARTs to find all connected slave modules.
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6. The software will compare the firmware version currently loaded on the module vs. the
firmware version available on the PC. If the module has the most updated version a
green check mark will be displayed next to that module. A red X will be displayed next to
a module with an older firmware version.

7. If any of the modules are not updated, a red bar will be displayed instead of the green
bar. Highlight the modules that require an update and select the update Module(s)
button to apply these updates. The firmware files will be downloaded to the module.

14 | Released: 3/16/15

Configure Slave Addresses
1. Every slave module on a specific UART needs to have a unique address. The first module
should have an address of 1.
2. Select Utilities > Slave Setup Assistant.

3. The Slave Setup Assistant window appears. Select the perform Scan button.

4. Another window appears with the list of all connected controllers. Highlight the
controller where the slave modules are connected to and click the OK button.
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5. All modules connected to the specified controller will be displayed.

6. Use the Address column to modify the address of the module.

7. Modules that have an address to be updated will have a red star in the first column.
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8. Select the write Changes to apply the new addresses.

9. The software will re-scan the controller and provide confirmation of the process.

Adding Controllers to a Project
1. The controller can be connected to after updating the firmware of all modules
(controller and slaves), configuring IP settings & PC firewall, and configuring node
addresses.
2. Right-click anywhere in the project workspace to access the add controller options.
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3. Select Add Online Controllers. The software will scan and display all connected
controllers. Highlight the controller to add to the project and select the OK button.

4. The software will read the configuration files inside the hardware.

5. The following window will appear when the process is complete.
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6. The controller and all connected slave modules will be displayed in the project work
space.

Configuring a Controller
1. Double-click on the controller to access the settings menu.

2. Detailed information about how to configure these settings can be obtained from the
following documents:




Q.bloxx Quick Start Guide
Q.brixx Quick Start Guide
Q.station Quick Start Guide
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3. If any settings have been modified on the controller or channel configuration of the
slave modules, these settings need to be updated to the hardware. Select File > Write
Project (Update).

4. The system will write the updated project files to the controller.
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5. Upon successful completion:

6. There are instances when test.commander will not allow the project to be updated to
the hardware. A red (not acceptable) or yellow (possible) screen will be displayed.

7. The type of error will be displayed on the design rule check screen. The source of the
error can be caused by several reasons including:








All variables do not have a unique name
Too many variables on a single UART
UART baud rate is either too fast or too slow
Controller’s update rate is too fast
Slave address configuration is incorrect
Incorrect interface settings (i.e. EtherCAT, CAN, etc.)
Incorrect data logger configuration

8. Modify the settings before attempting to update the project again.
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9. To check the validity of the project before attempting to update to the hardware, select
File > Calculate Statistics. Then select the Check button at the bottom of the Statistics
page.

10. If a white screen is displayed, the project is ready to be updated.
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Resetting or Reconfiguring a Controller
1. In the situation where the configuration of a controller needs to be overhauled, the
controller can be reset or cleaned. Resetting a controller applies the original factory
settings. Cleaning the controller maintains the current controller settings but erases the
slave module configuration.
2. In order to reset a controller, it must first be read by test.commander. With the
controller open in test.commander, highlight it and select Utilities > Factory reset.

3. Click Yes to confirm the process.

4. Cleaning the controller to remove the slave configuration files is useful in the situation
where the slave modules need to be rearranged or swapped.
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5. With the controller connected to test.commander, select Utilities > Cleanup Connected
Controller.

6. Click Yes to confirm the process.

7. The following window will appear at the completion of the process.
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8. Right-click on the controller in test.commander and select Remove Controller to erase
the configuration from the current project.

9. After reassembling/rearranging the hardware, performing the necessary firmware and
address settings, the controller can be added back to the project.
10. Since the controller was cleaned of any slave configuration files, test.commander will
ask if you would like to update the controller with the new configuration. Click Yes to
proceed.
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Naming Variables
1. As mentioned in a previous section, all variables within a single controller need to have
unique names. This can be performed one by one for each variable or in batches.
2. Before naming the variables in batches, let’s create some rules for certain groups of
variables. Select Extras > Settings.

3. Within the software settings window select the Var-names option.

4. Select the Add new rule button. Give the rule a name and click OK.
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5. Using the available rules, create a custom rule string in the cell provided. Click the OK
button to save. Previously created rules can also be deleted; select the rule from the
drop down menu and click the Delete rule button.

6. Back in the main project work space, right-click on the controller and select Assign
Names.
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7. The assign names window will open displaying all the configured variables within the
controller. If any variables have the same name, a red exclamation mark will be shown
next to those variables.
All unique variable names:

Variables with the same name:
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8. Variables can be named one by one here.

9. The more efficient method is to highlight a group of variables and perform a batch
rename. After highlighting the variables, perform a right-click and select the naming
scheme/rule to use.
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10. There are some predefined schemes to use:



Assign according to tree structure
Assign according to variable settings

11. One of the previously created rules can also be used. Click the OK button to confirm the
changes.

12. Make sure to update the project settings to the controller.
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Organizing the Project Workspace
1. After connecting to the controller, the individual modules will be displayed under the
controller. The various specifications of the modules can be displayed in the workspace.
2. Right-click in the header of the workspace to open the specification selection column.

3. The columns can be organized by dragging the columns to the desired locations.

4. The columns can be resized by dragging the columns left and right.
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Adjusting Variables using Online Values
1. It is possible to perform a point to point calibration of any channel using live values.
Make sure to perform any conversion to engineering units in ICP100 first.
2. Highlight the connected controller.

3. Select the Online adjust values from Controller.

4. The system will scan and connect to the highlighted controller.
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5. The Adjustment window will appear.

6. Open the available UARTs (i.e. Slave RS 485 #1 shown below).
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7. The individual modules are shown and the channels inside each of those modules.
8. Click on the variable to calibrate. Select the Adjustment button.

9. The online adjustment window will appear. Use one of the three available options to
perform the calibration. Click the OK button to confirm. Repeat the process for all
desired variables.
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Read Controller’s Buffer
1. The Gantner controller has configurable circular buffers, sometimes more than one (4
available in a single Q.station).
2. The current data in these circular buffers can be read and displayed in test.viewer.
Select File > Read Online Buffer From Controller.

3. The software will read the data files in the buffer.
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4. The data will open in test.viewer for further data analysis.

Read Online Values from Controller
1. It is possible to view live values within test.commander. This live data can also be
viewed within test.viewer.
2. Select File > Read Online Values From Controller.
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3. The View Values window will appear. This window displays live values from all channels.

4. Zero and Tare of channels (if previously configured) can be performed here. A check
mark can be placed within the Zero/Tare column next to the channels to calibrate.
Select the option from the drop down menu and press the Zero/Tare column.
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5. Click on the Set RTC button to open the real time clock configuration window. The real
time clock within the controller can be synchronized to the PC’s clock by pressing the
Synchronize button.

6. Select the Show online graph button to initiate test.viewer.

7. The only difference compared to reading the buffer option is the data is streaming live.
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Read Slave Information Online
1. Select File > Read Online Slave Info From Controller.

2. The slave information window will appear. This window will display information from all
slaves connected to the controller including:






Module address
Module type
Condition of module
Firmware version of module
Module serial number
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Read Controller Information Online
1. Select File > Read Online State Info From Controller.

2. The controller information window will appear. This window displays general states of
the controller including overall health, logger status, any error states, etc.
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Offline Mode
1. In all the modes discussed above, we have used test.commander in an “online” mode.
This means that actual hardware has been connected to the PC while test.commander is
used. The great feature that test.commander provides is the ability to use it in “offline”
mode. Essentially test.commander is always in “offline” mode unless project files and
data files are being read or written.
2. The benefit of having an offline mode is to create custom and theoretical projects to
verify functionality before assembling a real system.
3. Create a new project. File > New Project.

4. Give the project a name.

41 | Released: 3/16/15

5. Within the empty project workspace, right-click on the mouse and select Add Controller.

6. Any Gantner controller can be added, whether that is an e.series or Q.series controller.

7. Selecting a controller will add it to the project.
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8. Right-click on the controller and select Add Slave.

9. The slave module can be an e.series or Q.series module.
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10. The UART and slave address must be specified for each slave module that is added.

11. The casing/package can also be selected here.

12. Continue to add the necessary modules to the system. Pay close attention to UART and
slave address organization.
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13. Adding modules of the same type can be performed using the copy/paste method.
Right-click on the module and select copy:

Right-click on the controller and select paste:

14. With the desired slave modules added to the correct UARTs and configured with the
correct slave addresses, the rest of the system settings can be modified.
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15. Settings such as sample rate, UART baud rate, channel count, etc. can be modified.
16. After the desired settings have been configured, the validity of the project can be
determined. File > Calculate Statistics.

17. Select the Check button.

18. This will open the design rule check window.
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19. This window will help determine if any changes need to be performed to the software
settings and/or physical configuration of the system. This may involve reducing or
increasing the number of channels or modules, obtaining a higher performance
controller, changing the distribution of modules, etc.

Project Statistics
1. Knowing the data format and layout of a specific project is important especially for
various interfaces such as Modbus and Profibus. These are important information
required by the host system.
2. These statistics for every variable (real or calculated) are available in the statistics
window.
3. File > Calculate Statistics.
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4. This will display the required information for every variable within the current project.

5. Information provided includes:





Variable name, type, and format
Data format and direction
Register location: count and offset
Slave type, UART, and address

6. Navigate to each variable using the left and right arrow keys at the bottom of the page.
Fast forward between the first and last variable using the First and Last buttons.
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Exporting Projects
1. Projects can be exported to a zip file to be transferred to another PC. These exported
project files can also be used for archiving in case they need to be used for future
applications.
2. Select File > Export Project.

3. Give the zip file a name.

4. This zip file can now be moved to another PC to be accessed by test.commander.
5. This zip file can also be sent to Gantner technical personnel for evaluation and analysis.
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