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Introduction
Congratulations on your decision to use Gantner Instruments as your source for a high
performance data acquisition and control system. The software tool ICP100 is the tool required
to perform channel configuration within a Gantner measurement module. This guide will
review the different settings that can be modified using ICP100.
Purpose
The measurement modules of a Gantner system are the bulk of the entire system. These
modules not only acquire the signals from the sensors, but can also perform signal conditioning,
calculations, and filters to the aforementioned signals. ICP100 is the channel configuration tool
for any Gantner measurement module including ISM, e.series, and Q.series modules. ICP100 is
included with every copy of test.commander or can be downloaded as a stand-alone software
tool. A LICENSED version is required to obtain full functionality of ICP100.
Downloads
The latest and greatest version of ICP100 can be downloaded directly from the Gantner
Instruments website:
http://www.gantnerinstruments.com/software%20downloads/ICP100.zip

If ICP100 was originally obtained via test.commander, downloading the latest and greatest
version of test.commander will also download the latest and greatest version of ICP100:
http://www.gantnerinstruments.com/software%20downloads/test.commander.zip
Recommended PC Requirements







Windows XP
4 GB RAM
Dual Core Processor (2+ GHz)
Ethernet Port
USB Port
Data Storage (depends on application)
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Installation
1. Installing ICP100 via test.commander or as a stand-alone tool is a similar process. We
will review the installation process as a stand-alone tool.
2. After downloading the software from the website, unzip the file.
3. A Setup.exe file will be found in this unzipped folder. Double-click on this file to start the
installation process.

4. The Setup Wizard will appear.

5. At the end of the installation process:
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Licensing
1. Obtaining a licensed version of ICP100 can be performed in 2 ways. The first is via a
licensed version of test.commander and the second is obtaining a license for a standalone ICP100. For more information regarding a test.commander license, please refer to
the test.commander guide.
2. Inquire with your local Gantner vendor on how to obtain an ICP100 license.
3. The ICP100 license is represented in the following format:
Company: ICP100
Name: ADVANCED
Code: ICP100-XXXX-XXXX-XXXX-XXXXXXXX
4. Start ICP100 by double-clicking on the icon.

5. Within ICP100, select Help > About.

6. The About window will display the software in DEMO mode. Click on the License button
in the bottom right corner.
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7. Enter the license information in the spaces provided; click the OK button to confirm.

8. If entered successfully, the software will be converted to LICENSED mode.
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Language Settings
1. ICP100 can be used in 1 of 3 languages:




English
French
German

2. To modify the language settings, navigate to Utilities > Settings (i.e. Einstellungen).

3. With the Language option selected, choose the desired language.

4. Restart the software for the changes to take effect.
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Sensor Database
1. Gantner has many built-in standard sensor types for our various modules. However,
these sensors can be scaled and customized for any application.
2. To access the sensor database, select Utilities > Sensor Database.

3. The sensor database window will appear. Select the module from the drop down menu
to display the standard sensors within that specific module.
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4. Highlight the type of sensor to modify, and then click on the Copy button.
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5. Give the new sensor a name.

6. The new sensor will be added to the list.

7. Click the Edit button while the sensor is highlighted to open the edit sensor window.
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8. The window is organized into 3 separate tabs:

General: This tab displays information about the sensor.

Measurement: This tab displays the measurement principle used for this sensor as well
as all available measurement principles. Each principle can be moved back and forth
between the chosen and available sections.
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Unit: This tab displays the available units that the sensor can be equipped to use. Any of
the pre-set units can be used or edited. Add a new unit if desired one is not available.

Enter a combination of factor and offset to scale the unit.

The default precision of this unit can be entered in the space provided.
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9. A custom scaling table can be created for any sensor. Click on the Lineariz. button.

10. Select the unit to be used for the customization.

11. The sensor linearization table will appear.
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12. There are 300 individual measurement points that can be entered for each sensor.

13. Edit the measuring point one by one or export the table into a spreadsheet that can be
imported back in at a later time.
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Connecting to Modules: ICP100
Via Gantner Controller
1. Measurement modules connected to a Gantner controller can be accessed via the
Ethernet port of the controller. In ICP100, select Communication > Parameters.

2. The communication window will appear. In the interface kind drop down menu, select
TCP/IP Socket.

3. Enter the IP address of the controller and the port number of the UART where the
module is located. Click the OK to apply the settings.
UART #

Port #

1

8010

2

8011

3

8012

4

8013
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4. To connect to the attached modules, select File > Scan Bus.

5. The software will scan the specified UART.

6. All connected modules will be displayed in the drop down menu located in the top
toolbar.
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7. Click on any of the modules to open that module in the workspace.

Via RS232 to RS485 Converter
1. A measurement module can connect directly to a PC using a RS232 to RS485 converter.
Gantner Instruments has two versions (depending on the connectors available on the
PC):



ISK101: DB9 connector
ISK103: USB connector

2. With the modules connected to the PC via the RS232 to RS485 converter, select
Communication > Parameters.
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3. In the communication window, choose RS232 Direct and select the COM port that the
RS232 to RS485 converter is connected to. Press the OK button to confirm the settings.

4. Select File > Scan Bus.
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5. The software will scan for any modules connected to the converter. These modules will
be displayed in the drop down menu of the top toolbar.

6. Click on any of the modules to open that module in the workspace.
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Connecting to Modules: ICP100 in test.commander
1. A system that consists of a controller and measurement modules is configured using
test.commander. ICP100 is included with each installation of test.commander and can
also be launched within test.commander.
2. Opening ICP100 for a specified module is as easy as double-clicking on the module
within the project.
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Firmware Updates
1. The stand-alone version of ICP100 can also perform firmware updates for measurement
modules. Make sure to have the most up to date version of ICP100 to have the most up
to date firmware of modules.
2. Connect the module that requires an update.
3. Select Utilities > Download > Firmware Update.

4. Highlight the module from the list of connected modules to update. Click the OK button
to confirm.
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5. Select the firmware file to update the module with. Only the firmware files for the
specified module will be shown.

6. The download process of the new firmware will begin.
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Module Info Tab
1. The info tab provides specifications about the connected module. This is mainly for
diagnostic purposes to make sure the correct module is being modified.

2. The module’s serial number, OS, and APP version are also displayed. This is helpful
information to provide Gantner technical support personnel with any support
calls/inquiries.
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Measure Tab
1. This tab displays live data of the configured channels within the connected module. The
following information is included:






Type – this shows if the channel is an analog input, analog output, digital input,
digital output, set point, arithmetic, alarm, etc.
Description – this is the name of the channel.
Value – the current value of the connected sensor or the value displayed if error
checking is activated.
Unit – the configured units of the channel.
State – the status/condition of the channel.

Variable Settings Tab
1. The variable settings tab is the main purpose of ICP100, to perform channel
configuration. There are 16 x slots available for variables; these variables can consist of
real or virtual variables.
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2. Certain real channel types can be configured on a module based on the type of module
it is. The remaining available slots can be used for virtual variables such as arithmetics,
set points, signal conditioning, and alarms. For example, the A101 shown below is a 2 x
channel universal measurement module. This leaves 14 x slots remaining for virtual
variables.

3. Types of Variables:
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ACRONYM

VARIABLE

AI

Analog Input

AO

Analog Output

DI

Digital Input

DO

Digital Output

AR

Arithmetic

SP

Set Point

AL

Alarm

SC

Signal Conditioning

4. Adding/Deleting a Variable: Click in the cell that intersects the empty variable row and
the Type column. The type of available variables will be displayed.

5. The new variable will be created.

6. An entire row can be selected by clicking on the variable number.
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7. Variables can be cut, copied, pasted, inserted, and deleted by right-clicking on the
variable number. This is a good way to organize, duplicate, and remove the variables
within a module.

8. A module will only allow you to create a specific number of real variables. The number
and type of variable depends on the type of module being configured. For example, an
A101 only has 2 x analog inputs, creating a third analog input will not be possible. In the
image below, the third analog input doesn’t have an available terminal.

9. The variables can be configured after they have been added to the table. The available
settings will vary based on variable type. The columns are configured from left to right.
Click in a cell to modify the contents (if applicable).
Variable Name > Sensor > Type of > Connection > Terminals > Format/Adjustment >
Range/Error > Additionals
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10. Variable Name – This gives the variable a unique identifier. All variables within a given
project must have a unique name. The name can have a maximum of 20 characters.

11. Sensor – This determines the type of sensor to connect to the channel. For example, if
the channel is setup as an analog input on an A101, it can be configured as a voltage,
current, TC, potentiometer, RTD, etc. In comparison, an analog input on an A104 can
only be configured as a TC or voltage.
The sensor window will appear and display all possible choices. Select the sensor from
the list. It is also possible to create a new sensor using the new/edit/copy buttons. This
feature is identical to the sensor database feature previously explained.
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12. Type of – This column provides additional specifics to the sensor (if applicable). For
example, if a Voltage sensor is selected the type of column can specify if it is a singleended or IEPE (for an A101 module).

In comparison, a bridge sensor has the following types that can be selected:

13. Connection – This column displays the wiring connection for the type of sensor selected.
Note: when using an external special terminal block (i.e. CJC or bridge completion),
make sure to use the connection diagram located on the terminal block itself.

30 | Released: 3/16/15

14. Terminals – This column displays which connector to use on the module. There are 2 x
terminals available on a module. Connector 1 is the top connector and connector 2 is
the bottom connector.

15. Format/Adjustment – This is one of the most important columns within ICP100; this is
used to configure the format and units of the channel.





Select or type in the desired units into the space provided.
Click on the scaling button.
Enter the scale factor of the sensor using 2 point calibration or factor/offset.
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In the example below, mV/V is being converted to lbs.

Zeroing and/or Taring for this channel can be activated here. Clicking on either option
will display the window below. Select how the zero and/or tare calibration is triggered.
Choosing via Host will allow test.commander to perform the calibration. Click OK to
apply.
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Click on the Direction button. In order to perform the zero and/or tare to the channel,
Input/Output needs to be selected as the data direction.

16. Range/Error – This column specifies the expected measurement range of the channel
(min/max). If the sensor/channel reads a measurement out of range, an error can be
displayed. This is activated by using the range error checking.

The following options are available when an error occurs:
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17. Additionals – This column configures any filters for the channel (if available). These
filters include averaging, lowpass, highpass, and bandpass.

Module Settings Tab
1. This tab is used to apply settings of the module including a comments section
(location/user name), the date/time the module was last configured, and other
communication settings.
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2. Communication settings can be set here:





Address
Protocol
Baudrate
Format

Updating a Module
After applying the settings for the module including channel configuration, communication
settings, and more it is necessary to send these settings to the module. Select File > Send To
Module.
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Offline Mode
1. The sections above explain how to configure a module that is connected to the
software. We consider this being in “Online” mode. In the situation when a module is
not available the software can be used in “Offline” mode. This allows the user to review
the different settings available on a module and what is potentially configurable.
2. To open a specific module, select File > Open File.

3. A list of the modules will appear, select which file to configure.
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4. The same tabs seen in the “Online” mode are shown except for the Measure tab.

5. Under the Module Settings tab, the various module types of the selected module can be
selected; from Q.bloxx, Q.brixx to Q.raxx with special connectors.
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6. After selecting the module type, refer back to the Variable Settings tab for more details
about the wiring/pin assignment of the connector.

ICP100 within test.commander
1. ICP100 is installed when test.commander is installed. Therefore a licensed version of
test.commander also provides a licensed version of ICP100.
2. To start ICP100 within test.commander, double-click on the specific module within the
project. Updating the settings to the module is performed by updating to the controller.
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Index
Channel Configuration with ICP100:
http://www.gantnerinstruments.com/datasheets/library/icp-100-channel-configuration.pdf
Zero/Tare Configuration: http://www.gantnerinstruments.com/datasheets/library/zero-tarefunctionality.pdf
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Contact Information
Americas
Gantner Instruments Inc.
9835 Carroll Centre Road Suite 100
San Diego, CA 92126
Ph: 888-725-6997
Fax: 800-303-5381
Email: info@gantnerinstruments.com
Web: www.gantnerinstruments.com

Austria
Gantner Instruments GmbH
Montafonerstraße 4
6780 Schruns / Austria
Ph: +43 (0) 5556 77463-0
Fax: +43 (0) 5556 77463-300
Email: office@gantner-instruments.com
Web: www.gantner-instruments.com

Germany
Gantner Instruments Test & Measurement GmbH
Heidelberger Landstr. 74
64297 Darmstadt / Germany
Ph: +49 6151 95136-0
Fax: +49 6151 95136-26
Email: testing@gantner-instruments.com
Web: www.gantner-instruments.com
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