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Preparation
Introduction
Thank you for selecting Gantner Instruments as your data acquisition solution. This quick start
guide will discuss how to use and take advantage of the test.viewer software tool as a part of
your complete DAQ system. This tool is included with every copy of test.commander. The
test.viewer program streams the data from the controller’s buffer. This data can be analyzed
and saved into various formats; tasks that are all accomplished within test.viewer.

Software Downloads
test.commander:
http://www.gantnerinstruments.com/software%20downloads/test.commander.zip
test.viewer: http://www.gantnerinstruments.com/software%20downloads/test.viewer.zip

PC Requirements
Minimum OS: Windows XP
Recommended RAM: 4 GB
Recommended Processor: Dual Core (2+ GHz)
Data Storage: Depends on application requirement.
1 x Ethernet port (minimum)
1 x USB port (minimum)

Accessories
CAT5 Ethernet Cable
DC Power Supply
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Software Installation
1. Install the test.commander software that was downloaded from the Gantner
Instruments web site. A full version of test.viewer is included in the installation process.
2. Unzip the installation file (test.commander.zip).
3. Within this unzipped folder is the Setup.exe file. Double-click on this file to start the
installation process.
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4. To install the newest version of test.viewer simply install the most up to date version of
test.commander.
5. If test.commander is being installed on the PC for the very first time, it will require a
license to convert the software from DEMO mode to LICENSED mode. Full functionality
of test.viewer is not possible in DEMO mode.
6. Make sure to prepare the hardware including all controller settings and channel
configuration before starting test.viewer.
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Starting test.viewer
1. Make sure the entire system has been configured and updated.

2. After updating, select the Read Online Values from Controller button.

3. The View values window will appear. Select the Show online graph button.
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4. test.viewer starts and is already streaming live data.

test.viewer Configuration
Window Configuration
1. There are various windows that make up the entire test.viewer window. Select View in
the toolbar to select which windows to display.

9 | Released: 3/2/15

2. The Toolbar includes the saving icons, print icons, and various view icons.

3. The Statusbar displays the rate at which the data is buffered and the total memory that
is being used by test.viewer to stream the data.

4. The Title displays the current date and time.

5. The Channel List displays all real and virtual variables available in the controller. Place a
check mark next to the channels to display. Selecting the File Structure button displays
all the channels in a list (left side image below) while selecting the Window Structure
displays the channels into groups based on the measurement module (right side image
below).
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6. The Value List can display the current numerical value of any channel. Drag the channels
from the Channel List to the Value List. Note: once a channel is added to the Channel
List, it cannot be removed unless test.viewer is restarted.

7. The Curve Window is the main portion of test.viewer. This section displays all the
selected channels in a trend graph format. Channels can be combined in the same group
or separated into individual graphs. The details for this section will be explained in more
detail in a category below.

8. The Process Window can be used instead of the Curve Window. This section uses
configurable Process Elements such as bar displays, meters, curves, and numeric to
create a custom HMI. To add items to the main section, Process Elements are dragged
from the selection window; channels are then dragged from the Channel List onto each
Process Element. Further details for this section will be explained in a category below.
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Settings
The settings menu can be accessed from the top toolbar.

1. FILE TYPES: An assortment of file types can be selected here. If a file type is selected,
this file type will open in test.viewer by default. At the most basic level, we recommend
selecting .ged and .dat files to be used with test.viewer.

2. LANGUAGE: After first time installation, the language settings for test.viewer might be in
German. To switch to English, select Einstellungen > Sprache (located in the top
toolbar), then select English.
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3. STANDARD DISPLAY SETTINGS: If a certain type of test is being performed and the curve
window was modified (visual specifications) to fit the current test, these display settings
can be saved for future instances of test.viewer. It is also possible to create a default
display setting that test.viewer will use each time it is used.
No Settings – If this option is selected, test.viewer will open using the internal default
display settings.

Apply Display Settings Anyway – If this option is selected, test.viewer will use the display
settings selected in the Standard Settings drop down menu. To create a display settings
file click on the Save Current Display Settings as button (make sure to configure the
curve window first to your desired look and feel). The file will have an extension of .ges
(Green Eye Settings). After saving this file, it can be selected in the Standard Settings
section.
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Apply Only if File has no Display Settings – Archived data files (i.e. .dat files) can be
opened using test.viewer. Sometimes these files have display settings included.
Selecting this option will use the data file’s display settings first; if the file doesn’t have
any display settings it will use the settings from the file selected in the Standard Settings
option.

4. ASCII LOAD OPTIONS: ASCII files can be opened using test.viewer. This section provides
options on how these files are loaded into test.viewer.

5. ASCII SAVE OPTIONS: The data that is streamed from the Gantner controller can be
saved to a data file (i.e. .dat, .txt, .csv, etc.). The format in which the data is saved can be
selected here.
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Data Streaming
The test.viewer software tool can be accessed in various ways. It can be started within
test.commander or as a stand-alone tool. Starting test.viewer via the Read Online Values from
Controller button automatically starts a live stream of data. Starting test.viewer as a standalone tool does not automatically start a live stream.
1. Depending on the current status of test.viewer, the data stream can be started or
stopped at any time. Select Online > Start/Stop Live-Stream.

2. Starting a live stream provides various options before the acquisition process.

3. If multiple controllers are connected to the same network as the PC, selecting the Scan
button will allow the user to select a specific controller.
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4. The amount of PC memory can be selected here:

5. The stream can be started by pressing the Start Live-Stream button. If only a certain
number of channels need to be select, this can be performed by pressing the Start with
Channel Selection button. Otherwise all channels will be included in the data stream.
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6. The data is being acquired and streamed in test.viewer. Selecting Online > Stop LiveStream will provide the ability to save the data to a file. Select File > Save or Save As.

Curve Window Configuration
Zoom In/Out
1. When data is streaming, it is possible to zoom in and zoom out on any portion of the
curve(s). Click and drag the section of the curve(s) to zoom in.

2. Continue to zoom in until desired view is achieved. The current stream of data will be
paused during the zoom in process (if the allotted memory has been reached).
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3. There are various options available to perform a zoom out. Right-click anywhere on the
curve and select Step Zoom to zoom out 1 step previous or select total re-zoom to zoom
out to the original view.

4. Performing a total re-zoom will provide the option to restart the data streaming process
(if the data stream paused/disconnected).
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Measuring Data
Right-clicking on the curve window will provide two measuring options: simple measure or
differential measure.

1. Selecting Simple Measure will provide a single cursor that can be dragged across the
entire curve window. The measured value of every visible curve is displayed.

2. Right-click and deselect Simple Measure to remove the measurement cursor from the
curve window.
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3. Selecting Differential Measure will provide two cursors and a differential measurement
table of all visible channels. Drag each cursor to the desired time position. The table will
display the current value of the left cursors, the current value of the right cursors, and
the differential measurement.

4. In the Differential Measure table, select View > Statistical Values to display additional
information.
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5. Min, Max, Mean, and Standard Deviation information are now included in the table.

6. Within the Differential Measure window, it is possible to Export the contents of the
table to a CSV file. Select Export > CSV-Export to File.

7. Give the file a name.

8. Data viewed in Excel:
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Creating Markers
1. Right-click anywhere on the curve window and select Create Marker.

2. The Create/Edit Marker window will appear. Configure the specifications of the marker
including name, position on the time axis, variable, and cosmetic options. Click the OK
button to apply the marker to the curve.
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3. The marker will be added to the curve.

4. Double-click on the marker to edit the properties. The marker can also be deleted in this
window by selecting the Delete button.
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Value Table
Data that is currently displayed on the curve can be viewed in a table. This feature works best
when the curve is not streaming live. Right-click anywhere on the curve and select Show as
Table.

Data Shown in Table:
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Formatting the X & Y Axis
1. Right-click anywhere on the curve window and select Edit > X or Y Axis.

2. The X-Axis properties window modifies the following:

The scaling can be set to standard, absolute time, relative time, XY display, or use a
channel as an axis. The scaling type can then be modified further:
- Auto
- Min/Max Fixed (shown below)
- Range Fixed
- Data Points Fixed
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3. When a non-time related axis is used, the format of the units can be modified.

4. The spacing between ticks on the X-Axis can be set automatically or manually using a
user specified value.

5. The color of the axis label can be modified along with the angle of placement.
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6. The Y-Axis properties window modifies the following. If there is more than one group of
curves, Y-axis for each curve is modified independently of one another.

The scaling can be set to linear, logarithmic, or decibel; either Auto or Manual.

7. The format of the units, ticks (auto or manual), and label of the Y-Axis are all available
here.
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Curve Options
1. Right-click anywhere on the curve window. Select Edit > Curve Options.

2. The properties for each curve can be modified one by one, or the settings can be applied
to all curves (OK for all button).

The style of the line and appearance of each data point on the curve can be changed.
The color of each curve can be changed also. Note: make sure to unselect the check box
next to Auto in order to change the color of the curve.
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Common Options
1. Right-click anywhere in the curve window and select Edit > Common Options.
2. On the Window Structure tab the type of window layout for all curves can be selected:

3. Based on the type of structure selected, the layout is displayed on the left side of the
page.
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4. The Common Options tab displays various window options including font size, text
colors, background colors, etc.
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Process Window Configuration
1. Access the Process Window by clicking on View > Process Window.

2. The process window will open in design mode. This mode allows the user to
add/remove/edit process elements on the process window.

3. To add an element to the window, drag the element from the selection window to the
main window. Right-click on the background and select Create > choose Element,
accomplishes the same task.
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4. The available process elements:

5. Populate the process window with all desired elements.

6. Each element can be resized after it has been placed in the process window. Drag the
element from the edges to desired size. Left-click and hold on the element to move
around the process window.
Right-click on the process element and select Settings to modify the available options.
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7. For example, the settings for a numerical value element provide options for font, colors,
and position modifications.

8. Adding a variable/channel to a process element can be done by dragging the variable
from the channel list to the process element. This task can also be done by right-clicking
on the process element and selecting Channel Selection.

9. Select the channel to add to each element.
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10. The elements in the process window will display their default settings after a variable
has been assigned to it.

11. To delete any element, right-click on the element and select Delete Element.
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12. After the design has been finished, right-click anywhere in the background portion of
the process window and select Save Settings. The settings are saved as a .gep file (Green
Eye Process Settings).

13. Any previously saved settings can also be loaded by selecting Load Settings.
14. After the process window has been customized, channels selected, and settings saved,
right-click on the background and select Switch to Run Mode (notice that the Design
label in the bottom right corner disappears).
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15. Select Online > Start Live-Stream to start the display process.
16. After the process window is in Run Mode and modifications need to be made, right-click
on the background and select Switch to Design Mode.

Saving Data
Not only can data be streamed and analyzed in test.viewer, the data can also be saved for
future analysis or exported to a CSV file for data management in a spread sheet software such
as Excel.
Data can only be saved if the data is not streaming live (Online > Stop Live-Stream).
1. Select File > Save As.

2. Give the file a name and select the type of file to save as.
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3. Data files saved in Green Eye format (.ged) can be opened using test.viewer. The
benefit of saving data as .ged is the ability to append multiple data files together at a
later time. These appended files must contain identical channel configuration.
4. Open a fresh and empty test.viewer.

5. Select File > Append File.
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6. Select the files to append together.

7. If additional data files need to be included after the main append has already been
performed, select File > Append File. The software will present the option to append
the new data based on the data’s time stamp or immediately after the current data.

8. Appended data in test.viewer can now be exported/saved as a single data file using File
> Save As.
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Help Section
1. test.viewer has a built-in help section that can be used a quick reference guide. To
access this guide, select ? > Help, located in the top toolbar.

2. The help guide will open.

3. If the guide does not open, your version of Microsoft Windows might need the
following tool installed first:

http://www.microsoft.com/en-us/download/details.aspx?id=91
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Contact Information
Americas
Gantner Instruments Inc.
9835 Carroll Centre Road Suite 100
San Diego, CA 92126
Ph: 888-725-6997
Fax: 800-303-5381
Email: info@gantnerinstruments.com
Web: www.gantnerinstruments.com

Austria
Gantner Instruments GmbH
Montafonerstraße 4
6780 Schruns / Austria
Ph: +43 (0) 5556 77463-0
Fax: +43 (0) 5556 77463-300
Email: office@gantner-instruments.com
Web: www.gantner-instruments.com

Germany
Gantner Instruments Test & Measurement GmbH
Heidelberger Landstr. 74
64297 Darmstadt / Germany
Ph: +49 6151 95136-0
Fax: +49 6151 95136-26
Email: testing@gantner-instruments.com
Web: www.gantner-instruments.com
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