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Q.uick Start GuideHow to create aest.con StudioProjectwith Q.station Test Controllers

PurposeThis guide describes how to create a test.con profgser Space and Real Tinfier a
Q.station including the initial setup in test.commander.

Procedure
1. Configure the Q.station and all attached measurement modules using test.commander/ICP100.

2. Make sure the PAftinctionality setting in the Q.station is activatddpdate the project to the
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3. There are 2 main kernels of the Q.station that we will review in this guide, the User Space and
the Real Time kernels. The User Space kernel is reserved faraptgaal program part of the
application. The Real Time kernel is reserved for the time sensitive portion of the application
where the arithmetics and logic resides.

4. Typically it is important to configure the Real Time kernel first.

5. Open test.con Studio

6. Project > New

7. Select the Q.station as the type of controller we will be using.

8. Give the project a name. Since we want to identify which is the Real Time project vs. the User
Space project we will include an RT to the name. In this example we willl&8TRT Click
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9. We will now create a new system that we can place tteget under.Placethe Real Time
project under this gstem, which we will simply caIESTClick Next.
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10. Select the type of kernel to use, in this case we will choose the RT. Click Next.

Project new - System kernel selecti

Curent project data

Project name: QSTATION_RT
Type: Qstation
System riame: QSTATON

Depending on type 3 system can consist of some kemels. Each kemel will work independertly. Each
kemel can take an own project. At this point you have to decide. which kemel should load the project

Please check. f this system actually contains projects for this keme!
List of cumently existing projects:

Addtional settings forteam work |

<Esd<l Next > || Frish | Cancel

11. Slect the template to use; there is only one option for theaREime. Click Next.

Curent project data
Project name: QSTATION_RT
Type: Qstation

System name: GSTATION
Kemel choice:  Qistation real time kemel
Addtional settings for team work

Role 3100

Choose template
Projects always base ontemplates, which have basic settings and corfigurations forthe type.

Q station R default

[Q station defaut template for real tme kemel
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12. Click Finish to accept the settings.

13. Load the complete library of function blocks: Project > Load Library
Select all desired libraries and click Load.

IAII library directories

1]

termz [Float] [¥3.

14. The Real Time project can now be created using Program Blocks and Mamrogiircture with
the function blocks in the directory of libraries.
The function block used ttommunicate with the measurement channels can be found under

Device Data Access Functions: Read Access and Write Access
E| Device Data Access Functions (W1.0/QS)
: Read access

.. Write access

15. To add a function block to the prigmming environment simply select the function blaoid
drag it into the work space:

Libraries IFavorites' Find I

- Arithmetic (V5.1)

1 - Control elements (V0.0) e .
E- Controller (Float) (V1.1) Arithmetic (V3.1)
- Converter (¥7.1) - Control elements (V0.0)
M Counter (Word) (V1.1) - Controller (Float) (V1.1)
- Debug and Control (V1.1) i

- Device Data Access Functions (V1.0/Q5) " Converter (V7.1)
2 - Read access - Counter (Word) (V1.1)
- Write access - Debug and Control {V1.1)

?i,gita‘,F,”tE‘r.mi).,, . E| Device Data Access Functions (V1.0/Q%)
- Read access

- Write access
[ Digital Filter (V1.1)

16. Specifically, for the Read Access and Write Access, a variable can be assigned to the function
block when it is added to the work space:
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-
Input variables M
Wariables | Data type | Data direction »
Timestamp USINTES | F
Trig1 FLOAT ln]
Trig2 FLOAT ln]
SetPoint FLOAT L]
Yariable 1 FLOAT |
Wariable 2 FLOAT |
Wariable 3 FLOAT |
Wariable 4 FLOAT |
Watiable § FLOAT | E
Yatiable B FLOAT |
Yariable 7 FLOAT |
Yariable 8 FLOAT |
Yaltage FLOAT 10
Bridge FLOAT ln] |
Temp FLOAT L]
&larm FLOAT |
TC1 FLOAT ln] =
C FLOAT L]
War b FLOAT |
Yar b FLOAT |
War 7 FLOAT |
War & FLOAT | -
4 I} | »
Com ] 5]
=

N—

17. A help section is avable for each function block. To Access this help section-cigiit on the

fu_nction block:

2
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: = PO G e PID-Controller (Universal) i
: | - roller (Fo
T2+ # Parameter Dialog... [2] PIDControler (Percent)
— ] FIDCorvoter (Unvrs) Symbol
Call Name... (samples):
Help ]
Select
Cut
......... Copy .
I
Delete B1
Without limit
Bleck Mumber... controller output
< ] ] b

18. After creating and completing the program, it is ready to be downloaded to the controller.

Run > Enter
Run > Logon to Target System
Highlight the MK175RT

Click Settings
f B
ME1TERT
f best.con. iuntime Device: [
Wersian: |
Program: |
Date: |
Size: [
State: [No connection
Caonnect | Close
Parameter | Errar
0K I
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19. Enter the IP address of the controller and click OK:

r Rl
TCPIPCom Target addressA ==

— Selected target

1P/ port - 1000
—Ping
zend |
Device
Dezcription

— Pazsword
I [ Save Password

Cancel |

.

20. After clicking Connect, the red icon will turn green. The device information will be displayed.

Click OK.
¢ B
e
i‘ test. con.runtime Device: [MEI7ERT

Versiorr W 1.3.02

Frogram: “DHNTHM'

Date: [17.0414 14:03:05
Size: |81 009 Bytes
State: |HU”
Connect | Cloge | Sethings |
FParameter | Errar | Stop |

ok | Cancel | !|

21. Run > Download

22. The software will ask you to save the project before dmading. We recommend choosing Yes.

i Y
test.con ﬁ

Shall the project be saved before the downlead 7

23. After saving the program will download to the controller.

Downloading program

Cancel

24. When the download is complete, the software will beoirline mode.
Notice that the light bulb will be Yellow if it is in online mode.
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@Project Edit StructureBlock Run  Options Tools Windows 7

a Q @

25. To edit theprogram, select Run > Offline or click on the Yellow light bulb.
Then select Edit > Configuration.

26. To download to the controller again, start from the Run > Enter step and repeat the process.

27. The application Real Time portion of the project is now complete. It is now time to configure the
User Space half of the project. Select Project > New.

28. Select the Q.station controller and give the project a nafoeour example we will use

TEST_UZlickNext.
roaoes A =

uuuuuu

Eﬁwvrwedm\lb S ey e i [ oy puH o fksintis dideg
s reac cefaut scings. = i ot o be rosted

S o iows youto mke e crenes

A5 (| e

Q.gate/0) pacte EEETR | testconmntime

[The system has mutiple logical @ station test o kemal Ead\kema{ n be Dmgmmmad
ncantncintl. Commurication between kemele i realz=d by Ui <0 calid sotware - s

Insert projec data
Project riame:
‘TES‘U_IS

Directory:
[C-PROGRAM FILES (X86)\GANTNER INSTRUMENTS\TEST.CON V5.0.0 (BUILD 05)\PROJEC

L q TEST_US
l—i TEST_US

| Motz [I Feish Canosl

29. The software will ask you want to choose a system to add the project to. Since we already
created a system earlier for our Real Time project, we will use the same one:
- Add a project to an existing system
- Choose the same System we used for&@al Time projedfor this example, TEST)
- Click Next

Curert project data
Project name: TEST_US
Type: Q.station

Assign project

Projects are aitached to systems. A system is a group of projects, loaded into diferent kemels. The keme
can exchange data among each other. You can create a new system oradd the project to an existing
system.

Ichme system
I\Ada a project fo an exsing system ~]

Information about selected system

Choose sysiem dredl
_CON V5,00 (BUILD 08)\PROJECT ENGLISH\TEST =

Sytemrame:  TEST
Type Q statior

[The system has muliple logical Q. staion test con kemel. Each kemel canbe progammed
independently. Communication between kemels is realzed by using so calied softwa

Lg TEST
Li, TEST_US

<Back W Cancel |
30. Select the kernel we want tase;in this project we will be using the User Space. Click Next.
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Project new - System kemel slecti

Current project data

Froject name: TEST_US
Type: Qstation
System name: TEST
Kemel choice

Depending on type a system can consist of some kemels. Each kemel will work independently. Each
kemel an take an own project. A this point you have:to decide, which kemel should load the project

Qustation real time| EEETTIES
kemel space kemel 1

[The @ station can have more then one logical Linux test con USkemel. These USkemelsworkin
Linux user space. In this device. & is possble {0 program the display. Other features for example are
the access to higher Linuc AP or SQL databases. Each test con - USemel can be programmed and .
Please check, f this system actually cortains projects for this kemel

List of curenty extsting projects:

‘Addtional settings for team work |

<Baok Nex > Finsh | cancal
| ——|

31. Now select the template of the User Space, we recommend using the U.App_T_DPA. This will

provide anyapplication with the most flexibility moving forward. Click Next.
e

Curent project data

Project niame TEST_US

Type: Qstation

System iame: TEST

Kemelchoice: @ atation user space kemel 1

Addtional settings for team wortc
Role number: 3200
Desciption

Ch
Frojects always base on tempiates, which have basic settings and confiqurations for the type.

mu App_T - User App with Q App-interface
U.App_T_DPA - User App with Q.App-nterface

Q station HMI defauit

[This is an UserApp tempiate based on data page basic inerface to G App =

<Back Next > Finish Cancel

32. Click Finish.
oot e, S| ]

Curent project data

Project name: TEST_US

Type: Qstation

System iame: TEST

Kemel Qstation user space kemel 1

System riame: U.App_T_DPA.- User App with Q AppInierface

Addtional sstings for tesm work

Role number: 2200

Descrption

Project drectory:  CA\..0 (BUILD O5)\PROJECT ENGLISH\TEST\TEST_US

<Back | e |[Fish Cancel |

33. The basic template of the project will load:
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DS A erm QA s W - Mm% A H 8 X
J1 ¢« [ o 1 & T ¢ T = T * 7 | I T
Context Description Diagram
+|  with intomal Task Description Diagram
AL template is Ps (DPA)

Template name: U.App_T_ DPA

History
oreate 0002013 V0000

34. Start by loading the complete library of function blocks. Project > Load Library.
Highlight all the libraries and click anad.

~
IAII librany directories ;I ﬂy E

35. Tools > Network PAC Scanner.
The software will scan for the connected controllers.
Select the User Space kernel. Click OK.

\1.] Netwark Scanner E\L
I[ Nr ‘ Location | Name | Firmware ‘ SNR | IP Address ‘ Port | MID |
1 Undef Q.station 101 DT ¥1.07 2013-09-04 750272 192168128 12360 175-7-6381921-

Programmable Realtime Kernel  MK175RT 192168.1.28 11000
T L R R - =

use passive mode (helpful when devices are behind & router or be blacked by & firewall]

36. Tools > Datapoint Administration.
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&1 Dt i st - G203 I

File Edit View ?

~Search op! User
Name: [ Data —al — ~| || 3200-

Access: ¥ [read =l

Name [ Data type Dimension [ System datapoint | 10 data point |
£ []10 data points
[Ccanio<c1
[Jcando-cz
[ Gantner Data
[ software-10
~[] Logger

37. File > Scan Device.
Select the User Space kernel of the controller. Click OK.

| | Netwerk Scanner [E=SEEr =
Nr. |Locatmn ‘Name ‘Flrmwara ‘ SNR | IP Address ‘ Port ‘MID
1 Undef Qastation 101 DT V1.07 2013-09-04 750272 192168128 12360  175-7-63819214

Programmable Realtime Kernel ~ MK175RT 192.168.1.28 11000

s e s el o e i et ol e by P oK
||
Stop Sean Cancel
L

38. The I/O connected to the Q.station will not be shown in the datapoint administration.

Close the datapoint administration.
[+ oate ot sminstation- 500~ T i

File Edit View 7

~Search op User
MName: [ Data —all - - 3200 -

Access: b [read =]
: Ll Project variobles — [ oata ope [ Dimensien [ system data paint__| Project variable |
&[]0 data points OF Timestamp UsINTE4 1
[Jcan1o-ct I
i [Ocanto<2
Y ot 0107 e

~[]M0_Q.bloxx D101 (Undef)
~ [JM1_Q.bloxx A101 (Undef)
~ [JM2_Q.bloxx A104 (Undef)
~ [CJM3_Q.bloxx A107 (Undef)
i w[]Softwared0
*-[OLogger

Close
(]

39. Tools > Mask Designer.
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The mask designer is the tool we use to organize and customize the HMI portion of the test.con

program.

¢ Mask-Designer
Edit Settings 7

ol s ]

Mask. and Dbiects | Resources |

: lm
x [0 width: [480
s [ Hese 0
Addtional selings

I Wisible ofter start

Visible in the designer

pemanent

40. Inside the mask designer, we can add and modify objects. Each object can be sized, colors
modified, style modified, and more. By default, there are 2 pages (140.NBHaBd and

150.Fonts). Th

ges can be modified to your liking (as shown below).

¢ Mask-Designer

"% A [ @

Edit Settings 7

Mask and Dbjects | Resources |

= B Hintergrundfenster

Bl 100.Navigation

headine

Right

Left

-EH 140.MDP1-Base
HH Size 1

=-Hci

Section 1

c2

=

Section 2
HH Main

i u.appAPlinfo

List2

List1

IDE-name

static_text_1

E‘E c3

H Section 3

= c4
Section 4
H 150.Fonts

=-HH 160.system state
c-EH Bart

i test

----- statictext

Display

This application has been developed with

test.con 5 Studio

Example Program {
Dino’ H| Name: [120HDP1 Base

Section 1 Section 2

Addtional settings

I Visible after start

Visible in the designer

i only when the mask it selected -

Section 4

Section 3

41. Let usreview how to add some basic visualization to a page in the mask designer.
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42. Click on the page to modify, in this example 150.Fonts.
The name of the page can be changed.

Click on the Additional Settings button to make modifications.
7 MaskDesigner % 8 - ST

Edt Settings 1

x |0 ‘Wich, (480

u [0 Heght (550

Lebtenal setinge

43. We have since chard the page name to Display Page.
Rightclick on the page and select new objéxtadd a new HMI object
c4

] Section 4
B E 160.system MNew Mask
E'E Barl New Object
]t Import..
- {p8g] static text
g stotc Export...

Delete

Additional Settings...
Visible after Start

Visible in the designer 4

To the Foreground
To the Background
One Level Upwards

One Level Downwards

44. The empty object will be added to the page. Give the object a name and change the type. The
object can be resized and location can be moved. Ghickdditional settings after selecting the
type of object.

obje

Name: ‘New object

Type: ‘unknnwn

width B0

5 |10
w10 Height: |50

W Visible after start

45. For this example, we will create a bar graph:
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Name: ‘Bar Graph

Type: ‘ Bargraph j

% [10 widh: [120

W |1D Height: |4DD

Additional settings ...

v “isible after start

46. After clicking on the Additional settings, we can make the following changes:
- Background color
- Obiject color
- Scaling

- Other objects have other setigs also

Mame: |Bar Graph

Type: |Barg|aph j
w |10 Width: | 120
w |10 Height: (400

Additional settings ..

¥ Visible after start

Bargraph Settings
Bar: Obiject:
[ Fe ] B

Marmal: Dividing:

Overmun: Scale

Mirimurn: Murmber of large tics: |11

Mawimurm: Murnber of small tics: |1

Cancel

47. Click OK to apply the changes. Close the Mask Designer.

48. Go to theData Process Task program.

49. Add a variable from the Q.station using the Read access or Write access function block.
E| Device Data Access Functions (V1.0/Q5)
: Read access
L. Write access

50. Add the HMI objectunction blockfor a bar graph to thevork space.
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E1- HMI Masks and Objects (V9.1)
. Bargraph

- Bitmap

- Bitmap Button / Switch
- Button

.. LED

.. List Box

- Mask

-~ Mumeric Input

- Slider

- Text

- Trend

51. When the HMI objectunction blockis added to the work space, the mask desigmagens to
select which object to assign to the function block.
Select theobject, in our example the bar graph.
The OK button will activate, click OK.
The masldesigner window will close automatically.

52. Notice that the function block for the HMI bar graph has been assigned to the bar graph in the
mask designeiRight click on any function block and click Help to via more details about the
function block

53. Thevariable from the measurement module is a Floating point variable, whereas the HMI bar
graph is looking for a word input. We will use the converter function block to convert from
floating point to word.

54. Run > Enter
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